Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a linux box (ubuntu) and I have a service provider that will only allow an IPSEC tunnel connection between his network and my linux box.

I have these details from the service provider:

Service Provider: Peer IP – Lan on service provider's side - 10.10.10.10/24

Linux box details: Peer IP - Lan -

Connection details: Phase1: Sha Aes 128 DH - group x Preshared – Lifetime – 24h

Phase2: Sha Aes 128 Lifetime – 1h

I am not sure which app I need to install on the linux box that will support this type of connection.

Any ideas?

share|improve this question
1  
read: wiki.ubuntu.com/VPN –  SpacemanSpiff Dec 21 '10 at 23:09
    
@Tom: Did you read it? IPSec is "Not covered on this page, so far" –  DerfK Dec 22 '10 at 0:50
add comment

1 Answer 1

There are two implementations of IPSec networking code for Linux. The first was FreeS/WAN's KLIPS driver for 2.4 kernels. The second was 2.6's own native IPSec driver. During early 2.6 versions the native IPSec had fairly serious problems which led to the KLIPS IPSec driver being ported to 2.6.

The kernel-level support is only a piece of the puzzle, IPSec requires a user-space daemon for key exchange. There are a number of these for Linux. OpenS/WAN descends directly from FreeS/WAN and can use either 2.6 native IPSec or the KLIPS modules (KLIPS being preferred). strongSwan is a fork from FreeS/WAN to use native IPSec only. There are also ports of the BSD IKE daemons for the 2.6 native IPSec driver: racoon/ipsec-tools from Free/NetBSD and isakmpd from OpenBSD.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.