Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just recently installed hyper-v server 2008 r2 on a dedicated server i have, but i'm having trouble enabling remote management.

Running the HVRemote - - tool seems to have yielded some positive results, and all tests on the server pass (firewall, permissions, etc), but client-side things are not working. I'm stuck at this step :

5: - Simple query to root\cimv2 WMI namespace FAIL - Simple query failed Cannot perform simple query against root\cimv2

Anyone could help me figure this out? I'm almost giving up and installing XenServer...


share|improve this question
What a coincidence! I just installed one and having similar problem. Are you on workgroup or domain? – Adrian Godong Dec 22 '10 at 7:14
workgroup.. I heard that doing this is a breeze in a domain environment... what a sad move by Microsoft. – Pai Gaudêncio Dec 22 '10 at 12:37
up vote 1 down vote accepted

Finally found out what was happening.. In my case both client and server are not part of a domain, and I am connecting over the internet.

The name you connect to in HyperV manager must be the same as the name you configured your server in "System Properties" (option 2 in sconfig on hyper-v server 2008 r2).

Example: Your server is called "SERVER" and is accessible over the internet via - when connecting you must only use "SERVER" in the connection profile.

Unless both server and client are on the same network, this is not going to work, so you will have to add an entry on your HOSTS file pointing "SERVER" to the real IP address of the server.

That did the trick for me. Hope it helps someone!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.