Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is the /etc/fstab entry of a raid system /dev/md4 that is controlled with mdadm and webmin on an ubuntu 10.04 64 server:

/dev/md4                                  /mnt/md4        ext3    relatime        0       0

We tried to switch off automatic forced fsck on rebotts, as we prefer to implement our own scheduled fsck routine by setting the last parameter of the line to 0 (ZERO).

But we found out the forced and automatic check still occurs on the underlying real disks, lets say sdb1 and sdc1.

How can we switch that off?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

See the man page of tune2fs:

-c max-mount-counts
    Adjust the number of mounts after which the filesystem will be checked
    by e2fsck(8).  If max-mount-counts is 0 or -1, the number of times the
    filesystem is mounted will be disregarded by e2fsck(8) and the kernel.

-i  interval-between-checks[d|m|w]
    Adjust the maximal time between two filesystem checks.  No postfix or d
    result in days, m in months, and w in weeks.  A value of zero will
    disable the time-dependent checking.

So tune2fs -c 0 -i 0 /dev/sdx1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.