Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The WebClient service always at "stopping" state. Of course the service itself does not work (I cannot access sharepoint folders using their UNC paths, for example).

Tried rebooting - the service goes to "stopping" right after reboot.

Tried enabling basic authentication as some recommend, did not help.

Tried killing the "svchost" process; the WebClient service then goes out of "stopping" state. Attempting to start the service, it gets stuck in "stopping" right away.

System is WinXP SP2.

share|improve this question

1 Answer 1

If you already applied the tip you mentioned (setting

   HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
      \Services\WebClient\Parameters\UseBasicAuth (DWORD)

to "1", reverting the value to pre-SP2., you could debug the problem using Sysinternals Process Explorer to see what resources the svchost.exe, which hosts the service is using. Use the command-line use "tasklist /svc" to determing, which svchost.exe process is hosting the WebClient service.


Update: Is installing Windows XP Service Pack 3 an option? Maybe something went wrong after having installed SP 2 which could be resolved by SP3?

share|improve this answer
    
Thanks, but it didn't help. Regarding the UseBasicAuth configuration, I tried it earlier and it didn't help. (makes sense because the sharepoint server works with XP SP2). In process explorer I did not see anything suspicious (at least I didn't identify anything as being suspicious). Also, by the time I see the svchost process in the process explorer, the service is already in "stopping". I'm afraid it will not give me an indication of why the service failed in the first place. –  odedn Jun 8 '09 at 12:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.