Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do you tell if all users will have the same frameworks you have installed on your system? For example, I have python 2.6 installed on Mac OS X 10.6. Are all frameworks the same for the same OS level?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

If you didn't install anything else on your machine, all installations of MacOS 10.6 will have what you have installed with the possible exception of libraries that might come with iLife, which is preinstalled on every new Mac but is not installed if you setup your system from scratch.

There might be minor differences coming from installed patches, but those doesn't affect compability.

share|improve this answer
    
I installed XCode. How can I be sure that stuff like the python interpreters come packaged with the base system and not the SDK? Is there any command to test a file's origin? –  Juan Dec 22 '10 at 18:54
    
XCode's purpose is to write software for MacOS and as long as you don't write software to enhance/modify XCode's components (like the IDE, the Interface builder or Instruments), it will never require your users to install additional software to run programs written with it. Python comes preinstalled with MacOS. –  SvW Dec 22 '10 at 20:25
    
So there is no explicit way to know this? How do I know which versions of python are available for Mac OS X 10.5 and earlier? I guess I won't be porting my application back then. –  Juan Dec 22 '10 at 23:43
    
I am pretty sure it's documented on Apple's Developer site (developer.apple.com), did you look there? –  SvW Dec 23 '10 at 9:45
    
Looking here, it says that Python.framework has been available since 10.3, but doesn't saw which python version was on each one.developer.apple.com/library/mac/#documentation/MacOSX/… –  Juan Dec 23 '10 at 19:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.