Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One of my users takes his laptop home, connects to his home network fine. He brings it in every morning and since Monday - every morning it pulls the wrong DNS every time. It pulls 1 DNS: 192.168.1.1 which is the router. The DNS are external IPs.

I have several users that take their laptops home and connect to other networks - what could cause this anomaly?

He's booting up when he comes in the office and a simple ipconfig /release /renew fixes the issue.

share|improve this question
1  
When you say he is booting up, do you mean the OS boots from a clean state, or that he is simply resuming from a suspend/hibernate? –  Zoredache Dec 22 '10 at 19:12
    
OS boot - clean state. –  bradenkeith Dec 22 '10 at 19:21
2  
Since it sounds like the issue is localized to the client machine, perhaps you could help us by telling us the client OS, patch/servicepack level. –  Zoredache Dec 22 '10 at 19:46
    
How about some details, such as what the machine's settings are and what you have checked so far? Give us something to work with. –  John Gardeniers Dec 22 '10 at 21:19

3 Answers 3

Is both wireless and wired enabled? I wonder if at some point he tried connecting to a wireless network close by the office and now that is saved in his wireless networks list - which if the wireless adapter has priority it might choose the dns setting for that network over the wired network. Next time he comes in the office and it gets the 192.168.1.1 DNS address - before fixing it try navigating to http://192.168.1.1 and see if anything is there.

share|improve this answer
    
Good answer. I have seen something similar happening in the past. Some users home-router was an out-of-the-box linksys that supplied 192.168.1.* to his home and he never changed the SSID from the default "linksys". Then somebody next to our office put a same model linksys online with the same settings (Same SSID, ip-range, no encryption). All sorts of weird stuff happened. This particular problem was most prevalent in the XP-pre-sp3 days when many WIFI adapters used proprietary Wifi connection utilities that presumed to "improve" the XP network stack. –  Tonny Jan 19 '12 at 21:50

192.168.1.1 is a default address for many home routers. I might think that your user's laptops receive their leases from home routers and then reject dhcp offer from your server. Perhaps I would check if your dhcp server is set as athorative or not.

share|improve this answer

copy the lmhosts and hosts file from a computer that works ensure that there are no custom dns settings in the tcp/ip advanced /dns dialog box for that particular adapter. take a look under msconfig and regedit for that user what services startup. There can be a malware or service that may modify the dns settings

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.