Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

How do you keep Num Lock on when entering a virtual machine in VMWare Workstation 7.1.0 on Windows 7 x64 so you don't have to enter that key every time?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Go to EDIT SETTINGS on the VM, click on the OPTIONS tab and go to BOOT OPTIONS. Check the box that says "....force entry into the BIOS setup screen." Reboot and enter the BIOS. Go into KEYBOARD FEATURES on the main BIOS screen and change the Numlock state to ON.

share|improve this answer
Ok, great thanks! –  Chris_45 Jan 3 '11 at 17:44
I have it turned On but yet when entering the guest, it always goes Off. –  prl77 Aug 25 at 20:03

If you're using the free VMware Player, you can add or edit one of the following lines in the VM's .vmx file:

bios.forceSetupOnce = "TRUE"


bios.bootDelay = "xxxx"

The first line forces the VM to go into BIOS setup on the next boot.

The second line adds a delay to the initial POST screen, showing it for longer and giving you more time to access the BIOS setup, where xxxx is the number of milliseconds to show the POST screen. The maximum value for the boot delay is 10000 milliseconds or 10 seconds. After you change the boot delay, you can then enter the BIOS setup by following on screen instructions during POST.

Once you enter the BIOS, go to Keyboard Features and change Numlock to Enabled.

For information on how to find your vmx file, check here. For more information on Accessing the BIOS for various VMWare products, check here.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.