Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've a HP Pavilion DV4 with windows Server 2008 R2 enterprise. My system is connected to a domain. I login using my domain account. I am the administrator for the local machine. But I'm getting access denied everywhere (file system, running commands, using visual studio..literally everywhere..) in my machine. What could be the problem? Any ideas?

Please tell me if you need more information as I'm just a developer with less knowledge in system administration.

share|improve this question
    
Are you logging in to the domain or logging in locally? –  ErnieTheGeek Dec 23 '10 at 15:55
    
I've mentioned that I login using my domain account. –  NLV Dec 24 '10 at 5:25
add comment

1 Answer

up vote 1 down vote accepted

UAC is causing this. When in a domain auto elevation only works if you are either The Administrator (ie using that specific account, not just a member of Local Administrators) or you are a member of Domain Admins. There are ways around this but if all you need to do are local actions then selecting Run As Administrator should solve your immediate issues.

There is a complete explanation in this Technet article, including some options on how to modify the behavior.

share|improve this answer
    
Thanks for the tip. I detached my lap from the domain couple of days ago and reattached it. That was the problem. I again detached it and reattached to the domain today and it solved all the issues. –  NLV Dec 24 '10 at 5:26
    
But I'm marking this as answer as most of the articles/forum posts suggest the same thing. –  NLV Dec 24 '10 at 5:26
    
I suspect that there is a GPO in the domain that changes the auto-elevation behavior that hadn't applied to your system originally for some reason. Removing and re-adding it might have given it enough of a kick to resolve it, or it might just have needed a reboot or two to take effect. –  Helvick Dec 24 '10 at 8:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.