Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have our company website hosted on a Linux machine. It is sending mail via postfix. The emails are working and being sent to all email clients like Gmail. However, we are not receiving the emails on our exchange server.

When we look at the logs, we see that the connection is being refused, presumably by the exchange server.

postfix/qmgr[11865]: DA6D42FF13: from=<main-guy@domain.com>, size=3166, nrcpt=1 (queue active)
postfix/smtp[12474]: connect to mail.sanitizeddomain.com[XXX.XXX.XXX.XXX]:25: Connection refused
postfix/smtp[12474]: DA6D42FF13: to=<awesome@domain.com>, relay=none, delay=172915, delays=172914/0.03/0.07/0, dsn=4.4.1, status=deferred (connect to mail.sanitizeddomain.com[XXX.XXX.XXX.XXX]:25: Connection refused)

We do run Barracuda.

We cannot telnet from the linux machine to our mail server b/c we get the same message.

share|improve this question

3 Answers 3

Firewall rules that block traffic to your Exchange server on port 25/tcp? Check firewalls/port forwarding. Maybe try to send to port 587/tcp (if it is available on your Exchange server).

share|improve this answer

Where is the linux server hosted? If it's inside your network, is there a chance that it is trying to hit the external (e.g. MX looked-up) IP of your mail system? If so, you need to direct traffic either to the external address of your Barracuda (if it's the perimeter device) or the the internal address of your mail system.

Since this is postfix, you have the option of using a smarthost for your email relaying needs.

You can set this in /etc/postfix/main.cf

Edit this line: relayhost = your.mailserver.com

If the mail server is external, then you may need an exception/whitelist in the Barracuda spam filter. However, it doesn't seem as though you're getting that far. We really need to understand where these systems are located in relation to each other.

share|improve this answer
up vote 0 down vote accepted

Well we have fixed the issue but I must regret that I cannot give a more specific answer to the question. I'm told it is specific to our network and that is all that I know.

Thank you to those who responded for your efforts.

share|improve this answer
    
Negative vote? I'm sorry! I don't know the answer! –  Scott Dec 30 '10 at 21:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.