Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This was observed on Mac OS X 10.5, running Terminal.app. On a native Linux machine, from a bash command prompt, typing meta-backspace deletes up until the most recent whitespace. On a Mac, it sounds the system bell.

SSHing into a Linux machine with Terminal.app as the terminal causes the same problem.

This behavior is consistent with the third party application iTerm. However, the Windows program PuTTy handles meta-backspace (and other meta commands) as expected.

share|improve this question
    
I found an option in Terminal.app's preferences "use option as meta key" under settings icon, keyboard tab. By turning this on, I can get the functionality on the option key. Unfortunately, that's not the command key which is what I need. –  sludge Jun 7 '09 at 18:49
    
The command key is special, and efforts to use it inside a terminal aren't likely to work out. Why doesn't using option work? –  Bill Weiss Jun 7 '09 at 19:43
    
Because my desktop apps use command as meta key. The biggest example is Emacs. –  sludge Jun 7 '09 at 19:52
    
FWIW, Using option as the meta key - option-delete (backspace) works as suggested in the question. If you change the preference you have to make a new window in order for it to take effect - it doesn't apply to open windows. –  Chealion Jun 8 '09 at 0:17
    
Using the command key as meta is broken behaviour. You shouldn't try to break other apps so that they all match up. –  Dan Udey Jun 12 '09 at 7:49

2 Answers 2

The real solution to this problem is to use option as meta in the Terminal.app preferences and Emacs. In Emacs 23, I do:

(setq mac-option-modifier 'meta)

to use option as meta. Hope this helps.

share|improve this answer
    
The Emacs setting only applies if you're using a native Emacs application, not Emacs via a terminal. This question is about using programs via Terminal, so it's only necessary/useful to change the Terminal preference. –  Chris Page Jun 27 '12 at 3:14

You might consider using iTerm (iterm.sf.net) instead of Terminal.app... I find it's much more feature-complete than Terminal.app.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.