Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My dedicated Server has CentOS 5.5. I tried to install Plone, so I basically did:

wget launchpad.net/plone/4.0/4.0.2/+download/Plone-4.0.2-UnifiedInstaller.tgz
tar xzf Plone-4.0.2-UnifiedInstaller.tgz
cd Plone-4.0.2-UnifiedInstaller
./install.sh zeo

I ran into the following error:

Unable to find libssl or openssl/ssl.h.
If you wish to build without SSL support, run install.sh again with
--without-ssl flag.
Otherwise, install your platform's openssl-dev libraries and headers
and try again.

After this error I successfully installed openssl:

yum install openssl

And i tried to install Plone again. But I keep getting the error: "Unable to find libssl or openssl/ssl.h". Anybody an idea what I'missing?

share|improve this question
add comment

2 Answers

Development files for <package> are usually in <package>-devel. Install openssl-devel.

share|improve this answer
    
I just found the correct answer,too. But very quick reply, thanks! –  paskster Dec 24 '10 at 1:51
add comment

Ok, I found my error. I had to not only download openssl but also openssl-devel like so:

yum install openssl-devel
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.