Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been having a few issues with my company's VPN server. The VPN is running on a Mac Server (10.6.x) and I'm also using a Macbook (10.6.5). I've been building specific programs to gather information from IPs, and to work on this while I'm at home I need to go through our VPN to access the network. Unless I send all traffic over VPN, I'm not able to hit those specific IPs. However, I'm unable to access the internet through my web browser when I send all my traffic over VPN. I was wondering if there was a way (besides setting up a split tunnel) that I could set up a web browser to go through my current wireless connection, as opposed to going through the VPN like the rest of my applications. Wether the browser be Chrome, Firefox, or Safari doesn't matter to me.

Anyone else run into this issue and find a clever way to solve it? Thank you!

Edit: This might be what I'm looking for. My only issue is figuring out what I need to set for my IP addresses. Which IP address listed there should be my internal, wireless IP, and which one should be my office's network IP?

share|improve this question
What type of VPN are you using? I would suggest looking at setting up OpenVPN instead of any ipsec/pptp solution provided by the OS since you can have the VPN server push specific routes to the client. Which should address your routing issue. – Zoredache Dec 25 '10 at 15:10
It's just the default VPN that Mac OS X 10.6 provides for their server edition. I'll look into OpenVPN. Thanks. – Zachary Orr Dec 26 '10 at 3:29

The other option would be to install a proxy server (such as Squid) on your local network and configure your browser to use that proxy server. That does have to be on a system other than your Macbook.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.