Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a web application written by (c#) sql server 2005. we host it on 2 dedicated server ( IIS and SQL server ) From some month ago , in some days of week we have many reports about speed issue. we have some other application on this server using same database. when we have speed problem all aplication on these server have this problem, but applications on other server in same data center work correctly. ram and cpu usage are ok. how can I check that the problem related to internet connection or my application design? which parameters must be checked. Some other information In applications users can upload several files to server , each file up to 3 MB. we use a sql web admin application, on same server that has same problem, this is a standard application which work perfectly on other servers. -Ftp connection also is very slow - in local area network also application is slow too Thanks

share|improve this question
up vote 0 down vote accepted

I would look for DB deadlocks, expensive queries, table scans using SQL Server Activity Monitor and SQL Server Profiler. You can also check number of open connections using perfmon counters. Also, if TCP offloading (chimney) is enabled for the NIC, I would consider disabling that as well.

share|improve this answer
Number of connections is not more than 10 connections on DB.on login page which I use Asp.Net Membership also we have a long delay. – Ashian Dec 25 '10 at 13:44

in some days of week ...

=> Do you monitor the web transaction performance over time (e. g. with AlertFox)? Then you can see if the issue reoccurs periodically and at what time/day. If it does, it maybe is a simple issue such as running backup daily, or some other background process?

We had a similar issue with a background db backup that we found and fixed this way.

share|improve this answer
Thanks for your suggestion, I'll check it – Ashian Dec 25 '10 at 12:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.