Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a windows 7 computer which is connected via vpn to an OpenVpn server which happens to be in another country. I have all internet traffic being routed from my computer through the vpn to the server. However dns queries are not going through the vpn, but are instead going directly to my isp's dns via a route outside of the vpn tunnel.

This is happening because my wireless adapter is configured to obtain DNS server address automatically. The router that stands between my computer and the internet happens to have a DCHP server running on it that is assinging my computer with the DNS addresses of the isp. The issue is, i haven't been able to stop my wireless adapter on my computer from receiving the dns settings from the router. I've tried selecting 'use the following dns server addresses' and then just leaving them blank, but ipconfig /all shows me that this hasn't worked and i'm still getting dns form the router.

So is there any way to completely stop my windows wireless adapter from receiving these settings from the router? I have the OpenVpn server pushing to my computer's tun adapter the dns that it should be using. I'd rather solve this in a way that doesn't involve disabling the dhcp server on the router or fiddling with the router. The reason is i'm on a laptop and i want my vpn to not leak dns even when i'm out, for example in wireless hotspots. I know if i could just force the wireless adapter to ignore the router's dhcp server then my dns queries would go through the tunnel to the dns address pushed by the OpenVpn server.

Sorry, i know thats long winded, if you have any idea's please do tell me. Thanks and merry xmas.

share|improve this question

4 Answers 4

I've tried selecting 'use the following dns server addresses' and then just leaving them blank, but ipconfig /all shows me that this hasn't worked and i'm still getting dns form the router.

So why don't you just configure there the IP address of the DNS server in the VPN? Leaving it blank makes your windows to keep the previous config.

Hope that helps.

share|improve this answer

try some of the solutions here http://support.microsoft.com/kb/942440

EDIT: I think it should work everywhere as this does not involve changing the router settings

share|improve this answer

You can try to block the traffic of dhcp with some firewall software!!

share|improve this answer
    
the problem is not DHCP. –  Stemen Dec 26 '10 at 4:27

You can disable the wireless adapter, if you don't need it.

Or you can configure it with a static IP address; this way, it will not use DHCP at all.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.