Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I make a GET request to a CGI script and I get a 404 error. However, I am 100% sure that script is present and it has permissions:

-rwxr-xr-x  1 apache apache   6520 Sep  7 03:01

The request URL is:

The error I get:

The requested URL /cgi-bin/ was not found on this server.

This use to work for me before, but I think it stopped working after I restarted apache so maybe it means its a configuration I changed??

I checked the error logs for apache and php and nothing useful was found to help me with my problem!

I appreciate any help on this!

share|improve this question

migrated from Dec 26 '10 at 3:58

This question came from our site for professional and enthusiast programmers.

Where is the perl script located? – Pekka 웃 Dec 25 '10 at 22:56
Its located in /cgi-bin/ i.e. /var/www/vhosts/ – Abs Dec 25 '10 at 23:09
What's in your Apache error logs? What does the Apache configuration look like w/r/t to the /cgi-bin/ path? – larsks Dec 26 '10 at 4:21

1 Answer 1

up vote 1 down vote accepted

You have an error in your Apache configuration.

In your <VirtualHost> section you need

 ScriptAlias /cgi-bin/ "/var/www/vhosts/"   
share|improve this answer
Thank you so much. I didn't think to look in my httpd.include, the path to CGI was incorrect, I don't know how that happened! – Abs Dec 26 '10 at 14:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.