Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a PC where XenServer 5.6.1 fp-1 has been successfully installed.

I've manually set the network settings:

192.168.1.50
255.255.255.0
192.168.1.1

but it's set to xenbr0 iface. While eth0 is empty.

When I click on "Configure Management Inteface" it shows that eth0 is connected.

But when I ping a default gateway (which is 100% should be accessible) it fails.

I used to another shell (Alt+F3) and logged as root. I also failed to ping.

with both: ping -I eth0 192.168.1.1 and ping -I xenbr0 192.168.1.1

Be assured that:

  1. Cable works
  2. Ethernet adapter is 100% functional (prev OS was Ubuntu it was working)
  3. There is no firewall rule to deny anything. (everything is allowed)

So the question is:

What is a problem???

share|improve this question
1  
Got an older version of XenServer (5.6.0) working fine thanks! –  bakytn Dec 26 '10 at 17:36
    
Exactly the same problem here - thought I was going mad! –  Rob Nicholson Jan 19 '11 at 11:15
    
I had this problem with XCP 1.0. Bikerpete's solution below solves the problem. +1 –  Jacob Stanley Mar 19 '11 at 17:41

3 Answers 3

up vote 3 down vote accepted

Look here: C!trix Forum

After the update from my Citrix XenServer 5.6.0 to XenServer 5.6.1 feature pack 1 the network and the XenServer was unreachable. I couldn’t ping an IP from the network. The Mainboard is an ASRock P43TWINS1600 and the NIC is a RTL 8111/8168B PCI Express Gigabit Ethernet Controller.

With ifdown eth0 and ifup eth0 I tried to restart the NIC, but on ifup eth0 I got the error

Cannot set large receive offload settings: Operation not supported

I asked in the citrix forum (After update to XenServer-5.6.1-fp1 citrix xenserver unreachable) and I got the soluation (Thanks).

“An issue has been identified that affects some systems with Realtek cards. It will be resolved in the next hotfix. In the meantime try adding

options r8169 use_dac=1

to /etc/modprobe.conf.”

Hope it helps, Pete

share|improve this answer

When Xen after an update or hardware change your network adapter stops responding,your config seems alright and you can even ping 127.0.0.1 (but no IP of NIC or even gateway), exit to command line, and execute:

cd /etc
nano modprobe.conf

then add line in editor:

options r8169 use_dac=1
alias eth0 r8169 (this one was there before in modprobe.conf)

hit CTRL + x and Y to save file, reboot, pray and your prayers will be answered.

share|improve this answer

We Have the same problem...

With XenServer 5.6.0 it was no problem, but with the new XenServer-5.6.1-fp1 we can´t get the network to work...

Our network: 10.10.0.250 255.0.0.0 10.10.0.1

We tryed it on another server and it worked on one network card.. Not the other..

So i think it has problem with the hardware... or something..

We hope that CITRIX will fix this very soon!

share|improve this answer
    
In our server we have TWO NIC's. How much NIC's do you have? May be that's the reason? –  bakytn Jan 24 '11 at 5:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.