Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When logging in to a Debian Sarge install from cygwin, if I run top the output is "double spaced" for lack of a better word. The end result is that I can see the last few lines for the last few processes, but its not really usable:

28849 root       9   0  1896 1884 1392 S  4.6  0.5   0:01.36 dump

28861 root      12   0  1104 1104  848 R  1.6  0.3   0:00.14 top

    5 root      10   0     0    0    0 D  0.3  0.0   0:00.01 bdflush

    1 root       8   0   444  444  396 S  0.0  0.1   0:15.48 init

    2 root       8   0     0    0    0 S  0.0  0.0   0:00.01 keventd

    3 root      19  19     0    0    0 S  0.0  0.0   0:00.12 ksoftirqd_CPU0

I'm pretty sure this might be a termcap issue. Am I missing something simple?

share|improve this question
up vote 1 down vote accepted

The mailing list seems to suggest the new "native rxvt" instead of bash in a cmd.exe Window. I have just installed it, and I must say its quite nice. Solved the top problem and it does feel much more like a proper UNIX terminal.

For reference:

share|improve this answer

Works fine for me. I'd suggest running cygwin 1.7, its still beta but I've found it to be stable and has lots of improvements over the stable 1.5. Also, you will probably get better answers for this question on the cygwin mailing list.

share|improve this answer

It sounds like an issue with Cygwin. Do you have the same issue when using putty or another client?

share|improve this answer
No, putty is fine. I suspect that cygwin is setting the TERM value to something like cygwin, while putty seems to set it to something more reasonable: dcr1:/usr/share/otrs# echo $TERM xterm I'm not sure how to get cygwin to do the same. – Kyle Hodgson Jun 8 '09 at 16:50
Perhaps this can help: (no)tty - if set, Cygwin enables extra support (i.e., termios) for UNIX-like ttys in the Windows console. It is not compatible with some Windows programs. Defaults to not set, in which case the tty is opened in text mode. Note that this has been changed such that ^D works as expected instead of ^Z, and is settable via stty. This option must be specified before starting a Cygwin shell and it cannot be changed in the shell. It should not be set when using other terminals (i.e., rxvt or xterm). – MathewC Jun 8 '09 at 17:56
Sorry MatthewC. Nice try though. I'm reading that it has to do with the COLUMNS environment variable, something about it miscounting. seems to recommend that I not use the cmd.exe window, trying something I found there. – Kyle Hodgson Jun 9 '09 at 10:10
Sorry man. I don't have cygwin here to try and I was using your question to learn more about it myself. – MathewC Jun 9 '09 at 13:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.