Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I got autofs to mount a partition. It works fine, except I can't get it to mount with write privileges to regular users.

I tried with this in auto.master:

/misc /etc/auto.misc --timeout=60

and this in auto.misc:

data -fstype=vfat,rw :/dev/sda5

And I didn't get it to work.

When I was using fstab, the solution was to let users mount it passing the user mount option. Is there a way to make autofs mount stuff as the current user?

EDIT: forgot to mention, using the user option in auto.misc also didn't work.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Is there a way to make autofs mount stuff as the current user?

Not really, but what you could do is setup a group for users who will be allowed to have access to that resource, add all the users to the group, and then finally pass the gid, umask, and dmask options to set the group, and permissions the fat filesystem will use once it is mounted.

share|improve this answer
    
Thank you, this worked. It's not an elegant solution, but it works. It's also good because it gives me control over who can mount it. I don't need it right now, but who knows! –  Flávio Amieiro Jun 8 '09 at 1:35
add comment

Have you tried adding ",user" after the "rw" in auto.misc?

share|improve this answer
    
Yes, but it didn't work. Updated the question to mention that, I had forgotten. –  Flávio Amieiro Jun 8 '09 at 0:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.