Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have my personal profile's Documents folder redirected to a network drive H:\ . This was done by right clicking on Documents, Properties, choosing Location, and selecting H:\ .

I have a problem where some (I am not sure whether it is all) MSI installers will fail with an "Error 1327 Invalid Drive H:\" when I attempt to install them.

As a workaround, I can edit the registry at

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\

and set the registry key "Personal" temporarily back to "%USERPROFILE%\Documents", do the install, and then change it back. I don't know why this needs to be done though, as nothing is actually installed into that directory.

Does anyone have a more elegant solution?

share|improve this question
    
Does this belong on Superuser.com? –  kbyrd Jun 8 '09 at 1:30
    
Considering that site doesn't exist, no. –  Neobyte Jun 8 '09 at 1:47
    
...yet. [random rubbish to fill 15 chars requirement] –  Neobyte Jun 8 '09 at 1:48
    
Is the MSI being installed through group policy? –  Joseph Jun 8 '09 at 2:19
    
No I am running it manually. –  Neobyte Jun 8 '09 at 2:20

4 Answers 4

up vote 1 down vote accepted

Instead of mapping to the network drive "H:\", use the full UNC path: i.e. "\\server\user\docs"

This worked for me when I ran into the same issue~

share|improve this answer
    
As stated below, permissions could also be an issue if your are "Run As..."'ing the install. –  Tim Green Jun 16 '09 at 4:06

In Vista when installing a .msi package it's handled by Windows Installer which runs as the TrustedInstaller account. When it tries to access the msi package there's no such thing as H:.

The HKCU registry fix works because then the file will exist on your physical drive and thus be reachable by Windows Installer.

To avoid this type of issue you should never redirect a folder to a mapped drive, always use UNC paths when redirecting folders.

share|improve this answer

Is the MSI running as a different user, so it doesn't have H: mapped?

share|improve this answer
    
No it's not running as a different user (hence the HKCU fix working). –  Neobyte Jun 8 '09 at 2:17

This is occurring because the msi is using your home directory as temporary file storage. I would check to see if the permissions on your H drive are the same.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.