Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to host a small web server from my home network; however, I have not been able to successfully port forward ports to the local server. My current network topology looks like this:

Cable Modem/Router -> Secondary Wireless Router -> Many computers (including server)

The modem/router I'm using is a Cisco (Scientific Atlantic) DPC2100, provided by my ISP. The wireless router that I'm using as the central hub to my home network is a Linksys E3000. The computer being used as a server is running Ubuntu 10.04 Server Edition. The main issue is that I can't access the server remotely, using my WAN IP address. I have port forwarded my wireless router; however, I believe that I need to somehow set my modem to bridge mode. As far as I can tell though, this isn't possible.

Here are the various IP address settings:

DPC2100

WAN: 69.xxx.xxx.xxx
Internal IP: 192.168.100.1
Internal Network: 192.168.7.0

E3000

IP Address: 192.168.7.2
Gateway: 192.168.7.1
Internal IP: 192.168.1.1
Internal Network: 192.168.1.0

Server

IP Address: 192.168.1.123
Gateway: 192.168.1.1

Now I can do an nmap at various nodes, and here are the results (from the server):
nmap localhost: 22,25,53,80,110,139,143,445,631,993,995,3306,5432,8080 open
nmap 192.168.7.2: 22,25,80 (filtered),110,139,445 open (ports I have forwarded in the E3000)*
nmap 69.xxx.xxx.xxx: 1720 open

*For some reason, I can SSH into the server at 192.168.7.2, but not view the website.

Here are also some other settings:

/etc/hosts/

127.0.0.1       localhost
127.0.1.1       servername
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

/etc/apache2/sites-available/default snippet

<VirtualHost *:80>
        DocumentRoot /srv/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                ...
        </Directory>
        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                ...
        </Directory>
        ErrorLog /var/log/apache2/error.log
        LogLevel warn
        CustomLog /var/log/apache2/access.log combined
    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        ...
    </Directory>
</VirtualHost>

Let me know if you need any other information; some stuff probably slipped my mind.

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

You need to forward all ports (or at least the ones you want thru to your server) from the public port on the DPC2100 to the E3000.

But, is there a reason why you want TWO NAT-levels? If you can live with the E3000 just being an "antenna" for your local network, you can turn of its DHCP server, and connect the DPC to one of its LAN ports.

NAT = hassle, and two levels = more hassle...

share|improve this answer
    
Unfortunately, I can't port forward the DPC2100. There are no configurable options on it. I don't actually need or want two NAT levels, but that's just how the DPC works. Ideally, I'd want the DPC to be as transparent as possible, and have my NAT done by the E3000. –  sudo work Dec 28 '10 at 21:41
add comment

Similar to the other answer, here's how I'd do it:

DPC2100

WAN: 69.xxx.xxx.xxx Internal IP: 192.168.1.1 Internal Network: 192.168.1.0

E3000

WAN IP Address: Disabled Gateway: 192.168.1.1 Internal IP: 192.168.1.2 Internal Network: 192.168.1.0

Server

IP Address: 192.168.1.123 Gateway: 192.168.1.1

The E3000 will connect to the DPC2100 via a LAN interface, you need DHCP disabled as well, and it will basically become an access point with 4-port switch. Do your port forwarding at the DPC2100.

Tom

share|improve this answer
    
The DPC2100 does not allow for any configuration, including port forwarding. That's why I'm currently having issues. –  sudo work Dec 28 '10 at 21:39
    
Yikes. Buy something better, or bridge the modem to a decent router. –  Ablue Dec 30 '10 at 12:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.