Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Anyone got Dekiwiki / Mindtouch running with fcgid-module? I get 504 and 500 all the time.

 mod_fcgid: can't apply process slot for /var/www/html/dekiwiki/index.php
[Tue Dec 28 06:14:03 2010] [warn] (104)Connection reset by peer: mod_fcgid: read data from fastcgi server error.
[Tue Dec 28 06:14:03 2010] [error] [client 92.75.107.53] Premature end of script headers: index.php

I'm currently fiddling with SuExec and fast-cgi wrapper directory permissions, because I also employ a chrooted SFTP jail. Sometimes the first line about the process slot does not appear now.

I found a solution in german and will work it through now.

http://debianforum.de/forum/viewtopic.php?f=8&t=122758&start=15

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Enter in httpd.conf: LogLevel debug

It will work wonders for your /var/log/httpd/error_log file.

The rest is permissions, rewrite rules and understanding suexec (see apache docs)

Also pay attention to your php-fcgi-starter file settings. You have to export the PHP_FCGI_CHILDREN variable.

export PHP_FCGI_CHILDREN=8

Also see here (http://debianforum.de/forum/viewtopic.php?f=8&t=78073&start=105) [german]

This are the final configurations that worked for me:

php-fcgi-starter:

#!/bin/sh
#PHPRC=/etc/
#export PHPRC
export PHP_FCGI_MAX_REQUESTS=50
export PHP_FCGI_CHILDREN=8
exec /usr/bin/php-cgi

Make sure your dekiwiki-apache.conf is tidy and neatly nested. Enable any modules in httpd.conf for required options like ProxyPassReverse.

Make sure to nest the rewrite rules into the <Directory /var/www/html/yourwikiname> directive. Set AllowOverride All, make sure it isn't unset anywhere for that directory.

Another 'peace of the puzzle' that helped me was to use the latest mod_rewrite rules from mindtouch via SVN.

It's also important to set these values in httpd.conf according to the /usr/sbin/suexec owners.

User apache
Group chrootJailGroup

Don't forget if you change suexec's owners you have to set the suid again.

ls -lisha /usr/sbin/suexec 
-r-s--x--- 1 root chrootJailGroup 14K Aug 30 18:32 /usr/sbin/suexec
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.