Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Before upgrading to Service Pack 1 of Exchange 2010, OWA worked fine. We were able to do everything with no issues. After the upgrade, we can no longer delete messages within OWA unless we open up the message and delete it using the delete button inside of the message window. The error we get is this:

alt text

We've searched online and only found several posts pointing us to rename or delete the web.config file in the inetpub directory.

Any ideas are greatly appreciated.

share|improve this question
    
is there anything in your event logs? IIS usually puts something in there (granted, it's normally pretty cryptic, but a clue nonetheless). –  Ben Pilbrow Dec 30 '10 at 14:44

1 Answer 1

up vote 1 down vote accepted

It may be one of the many IIS config issues that arose from the Exchange 2010 SP1 upgrade. Just as a sanity check, I would urge you to look at the web.config file in the OWA IIS directory. Make a backup of the file before making any changes.

Open the file in an editor and look for a string resembling this:

<system.webServer>
   <httpRedirect enabled="true"/>
</system.webServer>

If that's present in that particular file, you should remove those lines and restart IIS. See if that works first. It was the core problem in my recent SP1 upgrade.

share|improve this answer
    
I tried it and it seems that it still doesn't work on some machines. We performed this on both of our Exchange servers and restarted IIS. Not sure why it's a hit and miss thing. –  Jason N. Gaylord Dec 28 '10 at 16:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.