Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've been having issues running anything in SQL Management Studio on Win 7. Basically, doing anything through the Management Studio interfaces completely freezes it up for a few minutes. Running a query is nearly impossible because it takes nearly 2 minutes just for the IDE to parse it and another minute to run it when the query itself completes instantaneously outside of the IDE. I'm not even going to go into the query designer. Anything with heavy user interaction such as editing a row in the result set where i have to click a cell freezes up the front-end. I tried reinstalling to no avail. Also tried running in compatibility mode without any difference whatsoever. Anybody had a similar experience?

I'm running SQL Management Studio 2008 version 10.0.2531.0 on 32-bit Windows 7. Connecting to a remote SQL Server instance (2008 R2).

Thanks.

share|improve this question
    
Have you tried disabling the Windows Firewall and then using SQLMS? Also, is the remote SQL server instance on the same network as you, or do you access it over the internet? I've used SQLMS 2005, 2008, and 2008R2 on both Win7 32bit and 64bit, and haven't seen this occur regularly like you are seeing, so it should work... –  KJ-SRS Dec 28 '10 at 21:29
    
@KJ-SRS Thanks for the suggestions. I tried disabling Windows Firewall but didn't see any difference. The remote server is on the same local network. The weird thing is that i'm the only dev at work with this issue. My coworkers are on identical machines, with the same install of SQL Management Studio, but i'm the only one who's having issues with it. –  Sergei Dec 28 '10 at 22:20

5 Answers 5

I had a similar problem. In my case, it was related to fingerprint reading software that ties into Windows Explorer. When I uninstalled HP Protect Tools, the performance of MS SQL SMS dramatically improved. After working with HP's support personnel (over the course of a few months) they gave me this solution:

For 32-bit OS: Unzip the customization per file and replace at the folder path:

“%ProgramFiles%\Hewlett-Packard\HP ProtectTools Security Manager\Bin\Coruscant”,

For 64-bit OS: Unzip the customization per file and replace at the folder path:

“%ProgramFiles(x86)%\Hewlett-Packard\HP ProtectTools Security Manager\Bin\Coruscant”.

Log-off and log-on back and verify the issue is fixed

Here is the XML file that was provided (it should be named "customization_per.xml"):

<?xml version="1.0" encoding="UTF-8"?>
<options>
  <processes>
    <process name="googletalk.exe">
      <classes>
        <class name="Google Talk - Google Xmpp Client GUI Window" type="runtimer"/>
      </classes>
    </process>
    <process name="msnmsgr.exe">
      <classes>
        <class name="DirectUIHWND" type="runtimer"/>
        <class name="MSBLWindowClass" type="runtimer"/>
      </classes>
    </process>
    <process name="yahoomessenger.exe">
      <classes>
        <class name="YahooBuddyMain" type="runtimer"/>
      </classes>
    </process>
    <process name="msaccess.exe">
      <classes>
        <class name="OGrid" type="nochildren"/>
      </classes>
    </process>
    <process name="msnmsgr.exe">
      <classes>
        <class name="MSBLWindowClass" type="forceload"/>
      </classes>
    </process>
    <process name="onenote.exe" type="skip" />
    <process name="corelcalc.exe" type="skip" />
    <process name="corellauncher.exe" type="skip" />
    <process name="corellaunchit.exe" type="skip" />
    <process name="corelshow.exe" type="skip" />
    <process name="corelwrite.exe" type="skip" />
    <process name="aim.exe">
      <classes>
        <class name="__oxFrame.class__" type="runtimer"/>
        <class name="__oxFrame.class__" type="forceload"/>
      </classes>
    </process>
    <process name="roxio burn.exe" type="skip"/>
    <process name="roxioburnreader.exe" type="skip"/>
    <process>
      <classes>
        <class name="SharedSigninDialogClass" type="forceload" />
      </classes>
    </process>
    <process name="ssms.exe" type="skip"/>
  </processes>
</options>

Hope that helps.

Sincerely, Stephen

share|improve this answer

Are any events recorded in event manager? Any other network related tasks slow? if you have other devs in your area and it works for them and they have rights to login to your pc try this as it may be a profile related issue.

share|improve this answer

Check and disable (if ON) the following settings in Internet Explorer options:

  • Check for server certificate revocation
  • Check for signatures for downloaded programs
share|improve this answer

I had similar issues with Visual Studio 2010 on Win7.

Eventually tracked it down to the Entrust Security Manager software which had made itself the default certifcate manager on the system.

Most likely the same issue as the finger-reader software mentioned above. Change the default certifcate handler back to the Microsoft one and the problem should disappear.

share|improve this answer

Override your registry keys by these below:

[HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\100\Tools\Shell\General\AutoRecover] "AutoRecover Always Enabled"=dword:00000000 "AutoRecover Enabled"=dword:00000000

share|improve this answer
    
You should take an extra minute to actually explain what this does instead of just posting a registry key and making anyone that comes across this research what it actually does. –  MDMarra Sep 28 '12 at 16:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.