Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
Time: 5280463 
Status: Has sent all binlog to slave; waiting for binlog to be updated

Is it okay that mysql replication process is idle for so long time?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

This depends on the type of queries. If you are doing only select statements, there will be no change in the data.

You can check the status of the slave using:

mysql> SHOW SLAVE STATUS;

If you find these two lines:

Slave_IO_Running: Yes
Slave_SQL_Running: Yes

This means that the replication is working fine. Otherwise, it may be broken due to invalid statement found on the slave machine. Check this link.

share|improve this answer
    
This works only from command line? I tried this on phpmyadmin database root account sql window, but it didn't write any response other than "Your SQL query has been executed successfully (Query took 0.0008 sec)". –  Richards Dec 29 '10 at 13:47
    
I did not try it on phpmyadmin. If so, I think you have to execute it on the mysql command line. Don't you have SSH access to your server? –  Khaled Dec 29 '10 at 14:05

The only reason I know of for the master to be idle is that there has been no activity to propagate (or at least no activity written to the binary log). Select statements would have no effect, as they are not written to the binary log. Only inserts, updates and deletes would propagate (as well as DDL).

How long is "long"?

share|improve this answer
    
5280463 seconds? –  Richards Dec 29 '10 at 13:42
    
Have you tried doing an insert on the master to see what happens? Also, I'd recommend checking as @Khaled recommended above. –  mlschechter Dec 30 '10 at 1:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.