Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running REHL 6 and just installed a Ubuntu Server Guest via KVM set to start at boot. This works correctly and the guest loads, but it loads "paused" and requires that I manually un-pause it. Can someone give me a hint as to how I can I get the Guest OS to actually become active on boot?

Here is the libvert dump as requested...Also tried libvert auto-start --- no effect.


<domain type='kvm' id='1'>
<name>MailServer</name>
<uuid>a61dae75-1f5c-d536-718f-3c615d9b4868</uuid>
<memory>4194304</memory>
<currentMemory>4194304</currentMemory>
<vcpu>4</vcpu>
<os>
<type arch='x86_64' machine='rhel6.0.0'>hvm</type>
<boot dev='hd'/>
</os>
<features>
<acpi/>
<apic/>
<pae/>
</features>
<clock offset='utc'/>
<on_poweroff>destroy</on_poweroff>
<on_reboot>restart</on_reboot>
<on_crash>restart</on_crash>
<devices>
<emulator>/usr/libexec/qemu-kvm</emulator>
<disk type='file' device='disk'>
<driver name='qemu' type='raw' cache='none'/>
<source file='/home/MailServer/MailServer-1.img'/>
<target dev='hda' bus='ide'/>
<alias name='ide0-0-0'/>
<address type='drive' controller='0' bus='0' unit='0'/>
</disk>
<disk type='block' device='cdrom'>
<driver name='qemu' type='raw'/>
<target dev='hdc' bus='ide'/>
<readonly/>
<alias name='ide0-1-0'/>
<address type='drive' controller='0' bus='1' unit='0'/>
</disk>
<controller type='ide' index='0'>
<alias name='ide0'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
</controller>
<interface type='bridge'>
<mac address='52:54:00:cd:f9:9f'/>
<source bridge='br0'/>
<target dev='vnet0'/>
<model type='virtio'/>
<alias name='net0'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
</interface>
<serial type='pty'>
<source path='/dev/pts/1'/>
<target port='0'/>
<alias name='serial0'/>
</serial>
<console type='pty' tty='/dev/pts/1'>
<source path='/dev/pts/1'/>
<target port='0'/>
<alias name='serial0'/>
</console>
<input type='mouse' bus='ps2'/>
<graphics type='vnc' port='5900' autoport='yes'/>
<sound model='ac97'>
<alias name='sound0'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
</sound>
<video>
<model type='cirrus' vram='9216' heads='1'/>
<alias name='video0'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
</video>
<memballoon model='virtio'>
<alias name='balloon0'/>
<address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
</memballoon>
</devices>
<seclabel type='dynamic' model='selinux'>
<label>system_u:system_r:svirt_t:s0:c211,c271</label>
<imagelabel>system_u:object_r:svirt_image_t:s0:c211,c271</imagelabel>
</seclabel>
</domain>

share|improve this question
    
run 'virsh dumpxml guestvmname > guestvmname.xml' and update your question w/ the contents. –  nedm Dec 29 '10 at 23:05
    
Thanks for posting the log -- nothing here stands out, to me at least. Next I'd take a look at /var/log/libvirt/qemu/guestvnname.log and look for any helpful info there. –  nedm Dec 30 '10 at 18:18
    
Thank you! I'll take a look. –  David Hamilton Dec 30 '10 at 23:09

2 Answers 2

up vote 1 down vote accepted

Probably not the best solution ever, but I did fix the problem. I added: virsh resume MailServer &> /var/log/MailServer.log to /etc/rc.d/rc.local

Might not be the most elegant way to force a start..but it works :).

Thanks for the help.

share|improve this answer
    
That's actually perfectly clever -- glad you figured out a workaround! –  nedm Jan 2 '11 at 4:03
    
Out of curiosity, is this the only guest on this host? Have you tried to fire up another guest and see if the same thing happens? –  nedm Jan 2 '11 at 4:04

if you know name of your domain you can do this

virsh autostart Domain
share|improve this answer
    
Thanks for the suggestion, but no dice. –  David Hamilton Dec 30 '10 at 23:09
    
virt-manager has also a checkbox for this... –  David Ramirez Mar 26 at 18:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.