Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to restore our Active directory infrastructure from System State backups. This normally isn't a problem but I'm trying to do it onto a Hyper-V based server while the backup "source" is a physical machine.

I've managed to get around the HAL problem by copying the HAL file from the source server after performing the active directory restore (when the kernel32.dll would have changed) and bringing up the windows server 2003 recovery console, then replacing the current HAL.dll in C:\WINDOWS\SYSTEM32

This worked and allowed Windows to boot, BUT when booting into normal startup I get the following error message

Directory Services could not start because of the following error:
The specified network password is not correct. Error Status:
0xc000006a. Please click OK to shutdown this system and reboot
into Directory Services Restore Mode, check the event log for more 
detailed information.
I am trying to restore from/to WIndows Server 2003 R2 SP1 with all the latest hotfixes. I am restoring from a P4HT based uniprocessor HAL to the same (specified processor type in System Center Virtual Machine Manager).

It has the same hard drive layout (one physical drive with one partition)

The backup file is only a few days old and therefore does not exceed the tombstone lifetime for the domain that is being restored.

THIS IS WRONG. Backup was very old indeed.

My gut instinct tells me that I'm fairly close to a successful restore but that I am missing something fundamental.

Hope you guys can help.

share|improve this question
    
Have jus/t found out that the last successful system state backup was done on Feb 18 2009. Which negates my tombstone lifetime not being exceeded. Why this has happened is another question I will need to interrogate someone for but I didn't catch it immediately as I trusted my backup server (which was collecting the backup correctly but it wasn't being executed on the source properly) I'll restore a new copy and see what happens –  Dan Jun 8 '09 at 8:23

2 Answers 2

Is the name of the restored server identical to the source server?

Update: Here is a potentially helpful KB article:

http://support.microsoft.com/kb/258062

share|improve this answer
    
Yes neobyte, it would be after a system state restore. It was not the same previous to this however. Do you think it would be worthwhile reverting to a snapshot and renaming the machine prior to the DSRM restore? –  Dan Jun 8 '09 at 7:38
    
It's worth a shot but I'll be honest and say I'm taking a guess saying it would work. I've updated above with a KB article that might help troubleshoot the cause. –  Neobyte Jun 8 '09 at 7:44
up vote 2 down vote accepted

This error also occurs if you have a backup that exceeds half the Tombstone Lifetime of the forest that you are restoring. This is a default value of 180 days.

A restore from a later backup (taken this morning) fixes the issue and allows the restore and restart of Directory Services to complete.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.