Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed oracle 10g on a ubuntu 10.x, This is my first time installation. After installing I tried to start it with the command below.

tsegay@server-name:/u01/app/oracle/product/10.2.0/db_1/bin$ lsnrctl

LSNRCTL for Linux: Version 10.2.0.1.0 - Production on 29-DEC-2010 22:46:51

Copyright (c) 1991, 2005, Oracle.  All rights reserved.

Welcome to LSNRCTL, type "help" for information.

LSNRCTL> start
Starting /u01/app/oracle/product/10.2.0/db_1/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 10.2.0.1.0 - Production
System parameter file is /u01/app/oracle/product/10.2.0/db_1/network/admin/listener.ora
Log messages written to /u01/app/oracle/product/10.2.0/db_1/network/log/listener.log
Error listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1)))
TNS-12555: TNS:permission denied
 TNS-12560: TNS:protocol adapter error
  TNS-00525: Insufficient privilege for operation
   Linux Error: 1: Operation not permitted

Listener failed to start. See the error message(s) above...

my listener.ora file looks like this:

# listener.ora Network Configuration File: /u01/app/oracle/product/10.2.0/db_1/network/admin/listener.ora
# Generated by Oracle configuration tools.

SID_LIST_LISTENER =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = PLSExtProc)
      (ORACLE_HOME = /u01/app/oracle/product/10.2.0/db_1)
      (PROGRAM = extproc)
    )
  )

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
      (ADDRESS = (PROTOCOL = TCP)(HOST = acct-vmserver)(PORT = 1521))
    )
  )

I can guess the problem is with permission issue, But i dont know where I have to do the change on permission.

Any help is appreciated ...

EDIT##

When i run with the command sudo, i got this

tsegay@server-name:/u01/app/oracle/product/10.2.0/db_1$ sudo ./bin/lsnrctl start

LSNRCTL for Linux: Version 10.2.0.1.0 - Production on 30-DEC-2010 01:01:03

Copyright (c) 1991, 2005, Oracle.  All rights reserved.

Starting ./bin/tnslsnr: please wait...

./bin/tnslsnr: error while loading shared libraries: libclntsh.so.10.1: cannot open shared object file: No such file or directory
TNS-12547: TNS:lost contact
 TNS-12560: TNS:protocol adapter error
  TNS-00517: Lost contact
   Linux Error: 32: Broken pipe
share|improve this question

migrated from stackoverflow.com Dec 30 '10 at 10:01

This question came from our site for professional and enthusiast programmers.

4 Answers 4

The listener must be started using the same account you used to install Oracle. Typically, this account is named 'oracle'.

Using sudo, the command line should be:

sudo -H -u oracle /u01/app/oracle/product/10.2.0/db_1/bin/lsnrctl start

(btw, I don't think that using Ubuntu to run an Oracle database is supported by Oracle)

share|improve this answer
    
Not supported but working very well: pythian.com/news/13291/… –  Dragos Feb 16 '12 at 11:47

Is your LD_LIBRARY_PATH set to include the Oracle library directories?

Did you run the root.sh script after you finished the installation?

share|improve this answer

After a painful process of installing the Oracle DB 11.2.0.1, Linux x86-64, on a Lubuntu 11.10 x86_64, involving many fixes of makefiles, a few remarks to make the listener work:

  • always use the Oracle DB install owner, e.g.: su - oracle
  • export ORACLE_HOME="/u01/app/oracle/product/10.2.0/db_1"
  • export LD_LIBRARY_PATH="${ORACLE_HOME}/lib"
  • export PATH="${ORACLE_HOME}/bin:${PATH}"
  • dbstart to start up the DB, listener should start automatically
  • lsnrctl status to verify it is really listening

It's better to permanently keep those 3 exports in oracle's .bashrc file.

If the listener status is still not OK, ensure that the oracle user is a member of a network-allowed group, in case of Lubuntu it's the group netdev. You can set this in System tools > Users and Groups > oracle > Advanced Settings > User Privileges > Connect to wireless and ethernet networks. Or alternatively just issue sudo usermod -aG netdev oracle using an administrative account, in your case tsegay. Remember to start a new shell (or logout + login) for oracle user to see the changes.

P.S.: My listener.ora is like:

LISTENER =
    (ADDRESS_LIST =
        (ADDRESS =
            (PROTOCOL = tcp)
            (HOST = localhost)
            (PORT = 1521)
        )
    )

SID_LIST_LISTENER =
    (SID_LIST =
        (SID_DESC =
            (GLOBAL_DBNAME = PLSExtProc)
            (SID_NAME = PLSExtProc)
            (ORACLE_HOME = /u01/app/oracle/product/10.2.0/db_1)
        )
    )
share|improve this answer
    
Lubuntu 11.10 ? Dear friend you are not canonical at all :) For best results Ubuntu 10.04 LTS. –  Dragos Feb 16 '12 at 11:50

You could try sudo lsnrctl, assuming you have sufficient rights.

share|improve this answer
    
Thanks, Please see above what i got when i run with sudo. –  tsegay Dec 30 '10 at 6:01
    
Well, perhaps an installation/configuration issue is similar to orafaq.com/forum/t/68299/2, orafaq.com/forum/t/81352/2 –  Raghuram Dec 30 '10 at 7:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.