Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A Dell x346 server crashed (motherboard went bad) and I need to get a few files off of the hard drive. They are 2 SCSI hard drives in RAID 1. As far as I know both drives are fine.

Can I just put one of the drives in another computer and get the data off?

share|improve this question
up vote 3 down vote accepted

Typically RAID1 isn't anything more than two normal drives with a bit of metadata at the end of the drive that the hardware RAID controller uses.

So it should be safe to put one of them in another computer. I wouldn't use a RAID controller for this just to avoid any potential for it reading and changing the RAID metadata in any way. Plus you typically have to do some low level RAID setup stuff for it to see a new drive which I would try to avoid if possible. But chances are that on a regular SCSI controller the drive will work fine and you can copy your data off.

If you want to be on the really cautious side just use dd to make an image of one of the drives and then mount the image using a loop device on Linux.

share|improve this answer

Was it a hardware controller doing the RAID, or was the controller merely acting as a connection and the RAID was done in software?

If it was a hardware RAID, you will need to plug the disks into the exact same model controller or you run the risk of damaging the RAID.

If it was a software RAID, you should be able to plug it in and it will Just Work (tm).

share|improve this answer
I was trying to figure that out. I think it was a hardware controller. So if that's the case I need to order a replacement motherboard just to use as a controller to get the data off? – evolvd Dec 30 '10 at 16:46
Unfortunately, yes, if the controller was built into the motherboard. You may also be able to find a different server with that same controller on it - sometimes the same chip is built into different motherboards. – Scrivener Dec 30 '10 at 16:47
I know of software such as would this also be an option? You said that I run the risk of damaging the drives if I try it in a different controller, how high is that risk? – evolvd Dec 30 '10 at 17:01
You don't run the risk of damaging the drives physically - if there's no data written to the drives, they won't spontaneously fry themselves. They just won't be recognisable as a RAID array. Software like that will work if, and only if, that software has support for the hardware controller that your motherboard had on it. – Scrivener Dec 30 '10 at 17:03
You made it sound as if I tried to access the drives with a different controller I run the risk of damaging the data, that is what I was concerned about. Guess there isn't an easy fix for this problem. – evolvd Dec 30 '10 at 17:10

If it was RAID-1 and not RAID-0 or JBOD, then the drives should be exact copies of each other unless the raid hardware did something really weird. Most drives don't have a read-only jumper, that would have been ideal for experimenting. I would try putting one drive into a non-raid controller and seeing what happens. Worst case should be that there are no partitions detected on the drive because the raid controller did something weird or it wasn't RAID-1, just be sure that if Windows detects that you have a new drive and it needs to be formatted that you tell it NO.

I wouldn't put the drives into another raid controller except as an absolute last resort. The controller might not accept the drives until the controller is configured, and the controller may automatically "initialize" the array as part of the configuration.

share|improve this answer
Thanks for the tips, I'll give it a try in a non-raid controller first. I figured since it was RAID 1 and no parity was going on I might be able to do this. – evolvd Dec 30 '10 at 18:03

I had to do this once when a RAID controller failed, and a compatible replacement wasn't available. The drive's contents were normal except for a sort of RAID header at the beginning of the drive; unfortunately, this meant the MBR wasn't in the usual place, so the disk was effectively unmountable. What worked for me was to figure out the header size, then use dd skip=headersizeinblocks if=/dev/disk1 of=/dev/disk2 to copy its contents (minus header) to another (larger) HD, which I could them mount normally.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.