Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On ubuntu 10.04 the phpmyadmin config is a little bit scattered.

I want to set the loginexpiration time to zero, should never expire, this is a secured setup behind a firewall. I think it is 3600 by default but cannot find the setting.

Where is it?

Edit: I actually changed it in /etc/phpmyadmin/conf.inc.php which seems the recommended place for ubuntu. The other files mentioned below might be overwritten on updates.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I think that you want to change the value of LoginCookieValidity. This is defined and set in /usr/share/phpmyadmin/libraries/config.default.php e.g.

$cfg['LoginCookieValidity'] = 1440;

The documentation ( /usr/share/phpmyadmin/Documentation.html ) says this

$cfg['LoginCookieValidity'] integer [number of seconds] Define how long is login cookie valid. Please note that php configuration option session.gc_maxlifetime might limit session validity and if session is lost, login cookie is also invalidated. So it is good idea to set session.gc_maxlifetime at least as high is $cfg['LoginCookieValidity'] is set.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.