Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i'm searching for an answer for about 24 hours now and I still can't find any really useful help...

The problem appears as the following:

I'm running a debian server with Plesk 9.5.3 and qmail. Since a few weeks I'm not able to send mails to some particular servers (like web.de, aol.com). Hence I get failure notices like "Sorry, I wasn't able to establish an SMTP connection."

But when I try to send mails to gmail.com - it works! Gmail only reports a softfail in the mail header like so:

Received: from h1600XXX.?none? (DOMAIN2.TLD [XX.XXX.XX.XX])
Received-SPF: softfail (google.com: best guess record for domain of 
transitioning EMAIL@DOMAIN1.TLD does not designate 85.XXX.XX.XX 
as permitted sender) client-ip=85.XXX.XX.XX

This sounds like a dns problem for me, but I can't get an answer for that... What makes me wondering is:

  1. h1600XXX is correct, but it should look like h1600XXX.stratoserver.net, not ?none?
  2. DOMAIN2.TLD (first line) is different from DOMAIN1 (second line). Both are hosted on this machine, but is this correct? DOMAIN1 is the one I send this mail from.

Hopefully someone could help me! If you need more specific information, let me know.

EDIT:

My current /etc/hosts file looks like this:

127.0.0.1       localhost
85.214.18.25    h1600XXX.domain.tld       h1600XXX

And my DNS record looks like this:

v=spf1 +a +mx ~all

But I'm still getting this softfail errors and I'm still not able to send mails to some particular providers.

share|improve this question

2 Answers 2

The (DOMAIN2.TLD [XX.XXX.XX.XX]) indicates that google reverse-resolved the IP address you connected from and got domain2.tld as the answer. Typically this isn't a problem.

You do have two problems here though:

  • Your mailserver is not using the FQDN in its banner/EHLO command (this is causing the ?none?)
  • Your SPF record is incorrect so it looks like you're spoofing your own mails

Having not used qmail I don't know whether it has some sort of "hostname = foo" that needs to be changed to "hostname = foo.domain1.tld" in its configuration, but I've had problems like this if I set /etc/hosts up like:

85.XXX.XX.XX h1600XXX h1600XXX.domanin1.tld

(or .domain1.tld is missing entirely). The first hostname listed is supposed to be the "canonical hostname" so it needs to be changed to:

85.XXX.XX.XX h1600XXX.domain1.tld h1600XXX

As for the SPF record, you need to look for the TXT record in your DNS settings for domain1.tld of the form

v=spf1 ...

and fix it according to the guidelines here. The wizard on that site should help. If you've properly set up MX records and all mail for domain1.tld goes through your mailserver, then you probably just need

v=spf1 mx ~all
share|improve this answer

What do your qmail control files list as your domain?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.