Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Can someone explain why gem thinks I don't have builder >= 2.1.2 even though I clearly have 3.0.0?

jason@ve:~$ gem install rails --pre
ERROR:  Error installing rails:
        activemodel requires builder (~> 2.1.2, runtime)
jason@ve:~$ gem list

*** LOCAL GEMS ***

abstract (1.0.0)
activesupport (3.0.3, 3.0.0.rc2)
builder (3.0.0)
erubis (2.6.6)
i18n (0.5.0)
mail (2.2.13)
memcache-client (1.8.5)
mime-types (1.16)
polyglot (0.3.1)
rack (1.2.1)
rack-mount (0.6.13)
rack-test (0.5.6)
text-format (1.0.0)
text-hyphen (1.0.0)
treetop (1.4.9)
tzinfo (0.3.23)
share|improve this question
up vote 2 down vote accepted

The ~> 2.1.2 designation means "greater than or equal to version 2.1.2, but not including the next major version. With a three-component version like 2.1.2, this means builder 2.1.2, 2.1.3, 2.1.4, etc. are all valid but 2.2.0 or 3.0.0 would be invalid.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.