Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Today I tried to install SQL Server 2008 R2 Express on my computer but I the installation failed, it said that PowerShell must be installed on it.

My question is then, what version of PowerShell should I install? where do I get it?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

PowerShell 1.0 is required according to the Hardware and Software Requirements for SQL Server 2008 R2. If you're running this on an old version of Windows, you'll probably need quite a few other updates.

share|improve this answer

PowerShell 2.0 is the current release and will provide expanded functionality for SQL Server. You can download it from this page: PS2 Download

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.