Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed Amazon AMI 1.0 and logged in as ec2-user with key. Then I ssh and set a password with sudo passwd ec2-user

But now when I connect via SFTP I get: Disconnected: No supported authentication methods available. I use elastic IP and username ec2-user to connect.

share|improve this question
    
What have you done to try and solve your own problem? –  Drew Khoury Feb 9 at 0:10
add comment

3 Answers 3

If your SFTP program is able to use public keys it is possible to use the service without password.

setup a passwd if run $sudo bash it will take to root #

sudo -s is permanent su, from there it is possible to use passwd.

share|improve this answer
add comment

For ec2-user you need to setup a passwd if run $sudo bash it will take to root #

share|improve this answer
    
What is my root password? –  cholden Jan 3 '11 at 12:56
    
you dont need root passwd when you run $sudo bash it not ask you passwd it will take to root –  Rajat Jan 3 '11 at 12:59
add comment

If you absolutely need to SFTP in as root, Juan Hernandez's answer on StackOverflow will help:

The message "Please login as the ec2-user user rather than root user." is displayed because a command is executed when you login with the private key. To remove that command edit ~/.ssh/authorized_keys file and remove the command option.

Thanks Juan!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.