Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a WordPress blog I've migrated from another CMS, and I've being having a lot of problems with my permalinks structure: lots of articles give a 404, although they are there, somewhere, published.

The site is www.muycomputerpro.com (MCP for short), and for example an article that should be found is: http://muycomputerpro.com/Actualidad/Especiales/2009-las-grandes-crecen-en-la-bolsa

If I do a search on the search tool at MCP, the result is there (see EnlacesMCP-1.jpg)

alt text

But when I click on the link, our 404 error page appears (see EnlacesMCP-2.jpg)

alt text

The weird thing is, the article is published, and the permalink is the right one, as you can see on this screenshot of the WordPress CMS:

alt text

The permalink (below the title) is correct (http://www.muycomputerpro.com/Actualidad/Especiales/2009-las-grandes-crecen-en-la-bolsa/)

but it does not work. In fact, if I try to use the short link (http://www.muycomputerpro.com/?p=5023) the article does not show either.

I've accessed my WordPress DB and I've search the article to see if there is something wrong there, but from what I can tell all the fields are OK, here's a screenshot:

alt text

I really don't know what is causing this. The permalink structure should work (I'm using the "Custom permalink" plugin to preserve the old URLs that had a alphanumeric code at the end of the postname) and the permalink config on wordpress is "/%postname%/".

I really need help :(

share|improve this question

2 Answers 2

What does the custom permalink plugin do?

Based on your permalink config, I expect your URL to look like:

http://www.muycomputerpro.com/2009-las-grandes-crecen-en-la-bolsa/

But it seems what you're getting is:

http://www.muycomputerpro.com/actualidadespeciales2009-las-grandes-crecen-en-la-bolsa_we9erk2xxdappxe3wszfeattcoixxjqj02h-2fc-hollp0wcf4agtmew6zyefbwk/

Since all the other permalinks look to be correct, I suggest going to that post in the post editor, and editing the slug (right underneath the title). Delete all text in the slug box, then hit ok, and it should auto fill the slug correctly.

share|improve this answer
    
I've been "playing" with the system and I've deactivated the Custom Permalink plugin (<a href="wordpress.org/extend/plugins/custom-permalinks/">http://…) , and now the searches inside the blog work, but they link to that "strange" permalins. In this example, the friendly-nice URL should be: <href="muycomputerpro.com/Actualidad/Especiales/…; But for the moment I haven't been able to solve that :( –  javipas Jan 3 '11 at 14:31
    
You set a custom permalink structure to /%postname%/ in Settings->Permalinks right? That shouldn't cause Actualidad to show up anywhere, the link should be DOMAIN/TITLE-SLUG –  Richard June Jan 5 '11 at 14:32

I've been "playing" with the system and I've deactivated the Custom Permalinks plugin, and now the searches inside the blog work, but they link to that "strange" permalins.

In this example, the friendly-nice URL should be:

http://www.muycomputerpro.com/Actualidad/Especiales/2009-las-grandes-crecen-en-la-bolsa

But for the moment I haven't been able to solve that :(

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.