Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I log into WHM, I get this message:

The server was unable to lookup an an A entry for its hostname (server226.taxi.com). This is generally because the entry was never added. However this could also be the result of your nameserver(s) being down. If you would like to attempt to automatically add the entry, click here.

If I click "here" it does nothing and I still get the message. I'm not hosting websites for other people, just internal projects on our server. Does not having an A Hostname Record affect SEO or anything like that or is this just a convenience when setting up nameservers or something like that?

share|improve this question

closed as off-topic by masegaloeh, Sven Apr 14 at 15:19

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions should demonstrate reasonable business information technology management practices. Questions that relate to unsupported hardware or software platforms or unmaintained environments may not be suitable for Server Fault - see the help center." – masegaloeh, Sven
If this question can be reworded to fit the rules in the help center, please edit the question.

3  
Questions concerning the use of shared web hosting in a development environment are off-topic. –  Falcon Momot Jul 19 '13 at 6:58

2 Answers 2

I believe it wants to have a hostname because in some areas of the control panel it refers to the hostname instead of the IP address. When you click "here" it will have you set up an A record in WHM; but if you DNS is hosted elsewhere this doesn't do anything.

Generally speaking you should have an A record for the server, but I think functionally each service should work without any problems even if an A record is not set up. As long are you are comfortable setting everything up manually you should be fine.

share|improve this answer

This could be due to a variety of misconfigurations, not necessarily a missing A record (which isn't exactly necessary if you have a CNAME record pointing to an A record, or a AAAA record...). If everything is working as you expect it to, then don't worry about this. If things aren't working correctly, time to mess with the DNS.

Search engines generally see the same site you do, so if it's coming up correctly, chances are SEO will be correct too.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.