Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have encountered an issue between Internet Explorer 6 (SP2) and IIS, although it seems that IE6 is the primary cause of the problem. When I attempt to access one of our internal intranet applications that uses IIS Windows Authentication the application thinks that I am a different user instead of my main account. The account that is being provided is actually one that I use to log on to the remote system to access the hard drive, I have been able to verify this by examining the log files.

Thus, my question is if there is a way around this, besides using Firefox or not connecting to the hard drive?

Note that since this is a corporate machine I'm also unable to upgrade Internet Explorer to the latest version.

share|improve this question
    
Does you company support the "Save IE6" initiative? saveie6.com ;-) –  splattne Jun 8 '09 at 12:49

7 Answers 7

up vote 2 down vote accepted

On the same computer, do you connect to the same server which hosts IIS using a different account? For example to connect a shared network resource (folder share)?

To test, if this is the case, try to disconnect that account, reboot the client machine and try again.

Possible solutions:

  • start Internet Explorer using a secondary logon from the command-line (you may have to change the path to the IE executable):
   runas /user:DOMAIN\USERNAME "C:\Program Files\Internet Explorer\iexplore.exe"
  • access the file share with the normal account, if this is possible. You may have to set the permissions on the share and folders on the server
  • if you have to use the network share just for copying some files, you could use a script (batch) which connects, copies/... and disconnects like this one:
   net use x: \\SERVER\ShareOnServer password /user:username  
   ... 
   net use x: /delete

This link from the Microsoft support site may be interesting too:

Error message when you use user credentials to connect to a network share from a Windows-based computer: "The network folder specified is currently mapped using a different user name and password"

share|improve this answer
    
Correct, that is what I'm doing. I suspected that it might be the problem, but is there a way around having to disconnect and reboot? The application is under active development, so having to reboot after each deployed build is going be a bit time consuming. –  rob Jun 8 '09 at 12:57
    
With reboot I meant the client computer. –  splattne Jun 8 '09 at 12:58
    
Rebooting works, but is there a way around having to reboot? For example, is there a way to force IE to provide a given set of credentials? –  rob Jun 8 '09 at 13:05
    
I updated my answer, see the first solution option. –  splattne Jun 8 '09 at 13:21
1  
The runas command did the trick! –  rob Jun 8 '09 at 13:45

Check the Control Panel -> User Accounts -> Advanced tab -> Manage your passwords.

IE and other Windows components use this list to determine whether to login to network resources with alternate credentials, such as web sites enabled for Windows pass-through authentication.

Here, you can enter server names or wildcards where you use different credentials than the logged in user. IE can automatically add entries if you were ever prompted for Windows pass-through authentication to a web site and ticked the "Remember this password" checkbox.

share|improve this answer

The account that is being provided is actually one that I use to log on to the remote system to access the hard drive, I have been able to verify this by examining the log files.

That's almost certainly the issue. I didn't think it would apply to website access too, but I know that Windows servers really don't like to see authentication as two different accounts coming from the same system - for example, if you try to mount a share you have permission to as your "normal" account after mapping this c$ share with the account you use for that you'll get told you can't do it.

share|improve this answer

Are you accessing the application from the remote desktop? If this is the case, you will potentially be authenticated on that instance as a different user.

share|improve this answer
    
Nope, just accessing it through IE6, the only odd thing I might be doing is connecting to C$ on the same system via a different account name. –  rob Jun 8 '09 at 12:45

Some thought / options...

  1. Have you changed the user account on the Application Pool "identity tab"?

  2. Have you changed the website's "anonymous user" from IUSER_ to a real user and forgot?

  3. Have you "saved" an old set of credentials (like after clicking "remember my password") on a previous session. You will have to delete the account from within the Control Panel > User Accounts > Advanced tab.

share|improve this answer

You're using IE to access a windows share? What happens if you use Windows Explorer to map a drive (persistent) and then exclusively use IE to access the site?

Please let me know,

Thanks, -Mathew

share|improve this answer

This is an issue with saved NTLM credentials.

Location your saved credentials file at

Documents and Settings\Application Data\Microsoft\Credentials\<SID>\Credentials

Back up this file, then remove it and reboot. You should find that you are prompted for the correct username/password now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.