Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have administrative access on our network, but I don't manage the installation of all servers or software. On some of our machines instances of SQL Server 2008 have been installed which I need to be able to access, but since my account hasn't been explicitly granted a login, I can't get into.

Is there a way to get into the database without changing anyone's password (e.g. I could solve this by changing the password of the user who installed the instance, assuming they've set themselves up as admin, and then logging on as them, but I don't want to have to do this).

share|improve this question
1  
I'm going to be a bit boring and old fashioned and say "Ask the person who does have admin access to add you". –  RobM Jan 4 '11 at 11:05
    
We have an external company managing aspects of our network and it's they that have installed some of the SQL Server instances. Getting a request like this acted upon is not always straightforward or fast. –  adhocgeek Jan 4 '11 at 11:31
    
@Robert, good advice in general but there are exceptions. I have a similar issue because it's an inherited system and nobody currently with the company even knows who installed SQL Server on the machine. –  John Gardeniers Jan 4 '11 at 11:51
    
@John - you're right but in those cases the single user mode trick should work. –  RobM Jan 4 '11 at 12:06

1 Answer 1

up vote 3 down vote accepted

check this earlier post, it may be helpful. If SQL is not in production and you are authorized to start or stop it, then you can add yourself to the SQL engine as admin, if you are admin on the machine.

share|improve this answer
    
I've tried that now and it doesn't work. I still can't login even in single user mode. –  adhocgeek Jan 4 '11 at 11:05
    
are you part of administrators group? If yes and still doesn't work, what error you have? –  yrushka Jan 4 '11 at 11:20
    
Yes, I am. The error I get is simply "Login failed for user..." –  adhocgeek Jan 4 '11 at 11:29
    
just a guess: run cmd.exe console as administrator (C:\Windows\System32\cmd.exe --> right click --> run as administrator) Probably you are facing the UAC problem. –  yrushka Jan 4 '11 at 12:33
    
<insert swearing about UAC here>. That turned out to be the issue - all sorted now, thanks. I really, really, really, really, really hate UAC. –  adhocgeek Jan 4 '11 at 16:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.