Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to get a service to run under a domain account. When I try to add the account, I get the error

The account name is invalid or does not exist, or the password is invalid for the account name specified

I know the account exists and the password is correct. I am also having trouble adding it manually to the "Log on as a service" setting, I get the error

An extended error has occured. Failed to save Local Policy Database

After a day of research I'm starting to suspect it has to do with it being a 2008 R2 server trying to use a 2000 domain account. I've tried to change the LAN Manager authentication level and the Minimum session security looks okay per my Google digging. I'm not sure what else I can do?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I know that 2008R2 had trouble looking up SIDs when we tried to install vCenter that needed to run as a domain account on a 2000 domain. There is a microsoft hotfix available for it. Google for 2008R2 and vCenter and you'll find it.

share|improve this answer
    
I can't believe I didn't run into that. Guess I didn't search for the right thing. Thank You! –  NoDisassemble Jan 4 '11 at 18:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.