Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a VPS running Centos with Kloxo on and I was wondering how I would upgrade the PHP to 5.3 - It's currently running 5.2.6.

When I try and do a yum update I get the following errors:

    Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libpq.so.4 for package: lxphp
---> Package postgresql-libs.i386 0:8.3.7-umask.7 set to be updated
--> Finished Dependency Resolution
lxphp-5.2.1-400.i386 from installed has depsolving problems
  --> Missing Dependency: libpq.so.4 is needed by package lxphp-5.2.1-400.i386 (installed)
Error: Missing Dependency: libpq.so.4 is needed by package lxphp-5.2.1-400.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Any help would be greatly appreciated.

share|improve this question
add comment

2 Answers

You can use php53 from the yum repo

Centos5 has PHP 5.3.3 available,

Remove your current php

If you installed via yum you can also remove it that way

yum remove php

yum remove php-common

Then do "yum install php53"

Hopefully then the dependices will be resolved correctly. You might have to remove more but yum should tell you.

share|improve this answer
add comment

Compile from source. It's liberating and cool :)

share|improve this answer
    
Any tutorials/guides? –  Malachi Jan 5 '11 at 8:40
    
answer needs more detail. –  Jeff Atwood Jan 5 '11 at 8:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.