Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install some software on pfsense 1.2.3 but the scripts are complaining about not finding the dirname binary. I have done a find on the system but cannot find it, and google is not helping either.

share|improve this question
up vote 1 down vote accepted

Probably pieces (maybe more than just dirname) of stock FreeBSD that we don't include in pfSense as they aren't needed for firewall or related purposes. You can just copy over from a stock 7.2 release for 1.2.3.

share|improve this answer

I'd have thought it was part of the base system. Have you tried just typing dirname or which dirname, and see what comes back? Your scripts might be clearing $PATH and not include /bin or /usr/bin as part of the definition, causing this kind of error.

share|improve this answer
Yeah thats what I expected :( I tried doing a find / -name dirname ... its not there, so I am downloading freebsd 7.2 and will try to extract binary from there. – user65682 Jan 5 '11 at 3:10
It is part of the base install, but as Chris Buechler points out, not all of base is included in pfSense. – Chris S Jan 5 '11 at 14:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.