Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed a CentOS 5.5 and the default php package is 5.1.6. I want to install 5.2.9, so I added /etc/yum.repo.d/CentOS-Testing.repo

name=CentOS-5 Testing

php-5.2.9-2.el5.centos.x86_64.rpm is available

So I tried: yum clean all, *yum search php-5.2.9-2.el5.centos.x86_64.rpm* --> Warning: No matches found for: php-5.2.9-2.el5.centos.x86_64.rpm

What I am doing wrong ? Thanks for your help.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

You've told yum to ignore this repository by setting enabled=0 in the configuration. You can either set:



yum --enablerepo=c5-testing ...
share|improve this answer
Thanks, that was so simple ! one more question: It only list the 5.2.10 and not the 5.2.9, I tried : yum install php-5.2.9-2.el5.centos.x86_64.rpm --> No package php-5.2.9-2.el5.centos.x86_64.rpm available. – Bastien974 Jan 5 '11 at 21:51
I imagine that the more recent 5.2.10 package masks this version. If you really want the older version, you can do (a) download the package locally (wget‌​.rpm) and then install it with yum (yum install php-5.2.9-2.el5.centos.x86_64.rpm). This will pull in all the dependencies. – larsks Jan 5 '11 at 21:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.