Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can get the mount to work and as written in /etc/fstab:

//pcsprdvhost.prod.tsh.mis.mckesson.com/sftphome /sftphome2 cifs username=myuser,workgroup=domain,password=mypassword,noserverinfo,uid=tmadmin,gid=tibco,nounix,file_mode=0777,dir_mode=0777 0 2

this means that every directory under /sftphome2 looks like: drwxrwxrwx 1 tmadmin tibco 0 Jul 6 2010 D0000001

When I issue: chown -R D0000001:D0000001_admin D0000001

Nothing happens.

When I pull the uid and gid specifications out I get the system owner/group of root:sys

What I need to be able to do is change the sub-directories under /sftphome2 to whatever owner and group (and permissions) I desire versus the ones that are getting specified. How do I do this?

share|improve this question
add comment

1 Answer

Without the Unix extensions which you have disabled with the nounix option you can't do any ownership/permissions with CIFS. Without the extensions the only thing you can do is set the ownership/permissions for the entire file-system. For the Unix extensions to work, they must be supported on the server you are connected to. If these are not supported on your server, you may be out of luck. You may need to look at using a different network filesystem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.