Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Or at least, that's what I think is happening. There doesn't appear to be a debug command for this, or to see if something is in the routing table.

I'm testing out this setup in Packet Tracer. I have 3 routers and a webserver

From left to right, you have: Webserver -> Router1 -> Router2 -> Router3

Router1 and Router2 can succesfully ping WebServer. Router3 cannot.

Router2 has a default gateway set, to send all not-recognized data through its serial interface to Router1.

Like this: ip route Serial 0/0/1 Serial 0/0/1 being the connection to Router1

Router2 and Router3 have OSPF configured. From their "show run":


router ospf 1
 passive-interface Serial0/0/1
 network area 0
 default-information originate


router ospf 1
 network area 0
 passive-interface FastEthernet0/0

I was under the assumption that setting default-information originate on Router2 would give Router3 the needed information. What's going wrong here?

The interfaces are up. Ip addresses are with mask-range, clock rate is set at correct end. I don't know what else to check.

EDIT: I was going to post a screenshot, but now it's working all of the sudden. I opened the PKT file, repositioned stuff so the labels would be clear, took the screenshot and then ran the test again, to see where the real-time analyzer said the mistake was. And it worked.

I'm sorry to have taken your time over this. I'm flabbergasted over this.

share|improve this question
I suspect that Vatine has correctly diagnosed your problem, but to allow us to confirm, please could you provide a diagram showing your topology and which interfaces on each device connect to eachother? – Murali Suriar Jan 6 '11 at 14:25
up vote 1 down vote accepted

Is FastEthernet0/0 (on Router3) the link to Router2? If so, the "passive-interface FasthEthernet0/0" is the main reason it's not working.

In OSPF terms, a "passive interface" is an interface that matches one (or more) of the network ranges specified in the "router ospf N" section, but does not send OSPF announcements.

Sending OSPF announcements is necessary to form OSPF adjacencies between routers on a network (be it a point-to-point link or a broadcast network with multiple routers). Having OSPF adjacencies formed is required for OSPF route exchange to happen.

As far as debugging OSPF, there's quite a few things under "debug ospf", I don't have an IOS handy, but I am pretty sure you can get the kit to log all LSAs sent as well as received (or, indeed, all OSPF state changes that happen).

share|improve this answer
No, the link between R3 and R2 is on Serial0/0/0. I will post a screenshot – KdgDev Jan 6 '11 at 20:35
Scrap that, problem solved, for some reason... – KdgDev Jan 6 '11 at 20:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.