Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I start my Ubuntu system it attempts two DNS lookups. One to find out what my internet-routers external ip is. And one to find the IP of my PSTN-SIP-provider.

Both fails.

[Apr  7 22:14:54] WARNING[1675] chan_sip.c: Invalid address for externhost keyword: sip.mydomain.com   
...   
[Apr  7 22:14:54] WARNING[1675] acl.c: Unable to lookup 'sip.myprovider.com'

And since the DNS fails it cannot register properly a cannot make outgoing or incoming calls.

If I later, after bootup, restart asterisk everything works excelent.

Any idea how I should setup things so that either:

  1. Delay Asterisk startup so that DNS is up and healthy first.

  2. Somehow get Asterisk to re-try the DNS thing later.

Regards Leif

share|improve this question

migrated from superuser.com Jan 6 '11 at 12:12

This question came from our site for computer enthusiasts and power users.

    
Do you have static IP or DHCP? –  Jimmy Hedman Apr 11 '10 at 4:38
    
The external IP of my system is DHCP. –  leiflundgren Jul 17 '10 at 8:10

1 Answer 1

I managed to solve it by changing the start-order in /etc/rc*.d to get the DNS to start before asterisk.
However, following system updates had the tendency to push back the original start order. (At least I think so. I fixed it, it worked for a week, then stopped again.)

Since I upgraded the system to Ubuntu 10.04 it just works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.