Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Asterisk has a command line shell mode which I enter by typing asterisk -r at the linux command line.

Inside its shell the standard linux commands like | more or | less do not work. And the screen just whizzes past me with no way of scrolling back up that I know of.

However, I can't be the first person that has this issue. Solutions?

share|improve this question

migrated from Jan 6 '11 at 12:13

This question came from our site for computer enthusiasts and power users.

Have you tried Shift+Page-Up? It is the common way of getting back in the scroll buffer of your console. That might not be the perfect solution but you should be able to get to any point in the log you want to. Note that most consoles allow you to set how many lines of buffer to keep. So you can increase it in case it is not enough for you purpose.

share|improve this answer
Yeah, I tried that and it had no effect on the screen whatsoever. – AngryHacker Oct 12 '10 at 20:24
For me it works. How do you access the console / which terminal are you using? Are you running asterisk -r within a screen session? If you do see Darth Android's answer. – Tronic Oct 12 '10 at 20:27

Try running it from inside of a screen session. It supports scrolling back through the log with Ctrl+A,[. Because screen functions as a virtual terminal, asterisk need not have support for it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.