Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have some problems with a domain not working as expected. My registrar's controlpanel shows these records for mydomain.eu:

www A 111.222.333.444
* A 111.222.333.444

I use the nameservers of my registrar.

I get a correct answer if i do

dig www.mydomain.eu  
dig whatever.mydomain.eu

I can also ping/visit website etc with those adresses. But,

dig mydomain.eu

wont resolve to anything. I just get this:

    ; <<>> DiG 9.6-ESV-R1 <<>> mydomain.eu
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46837
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomain.eu.   IN A

;; AUTHORITY SECTION:
mydomain.eu.  1799 IN SOA ns1.binero.se. registry.binero.se. 1281647822 3600 240 1209600 3600

;; Query time: 77 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Thu Jan  6 01:36:31 2011
;; MSG SIZE  rcvd: 83

The same A-record setup work for another domain/server ip, but that domain has other nameservers. What am I missing here?

share|improve this question

1 Answer 1

That means you have no A record for just mydomain.eu. *.mydomian.eu won't match just mydomain.eu. You need something like:

    A 111.222.333.444
www A 111.222.333.444
* A 111.222.333.444

Then a query for just mydomain.eu should work.

share|improve this answer
    
Thanks! Now it works. –  matheus Jan 6 '11 at 17:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.