Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have apache2 installed on ubuntu 10.4

inside my var/www/ directory [amung others] I have a cakephp and a dvdcatalog directories. Each of which have CakePHP 1.3 installed.

I can access them both via localhost/cakephp and localhost/dvdcatalog

But the dvdcatalog shows up with no css styling.

They both have these files:

/var/www/cakephp/app/webroot/css/cake.generic.css /var/www/dvdcatalog/app/webroot/css/cake.generic.css

But when I go to http://localhost/cakephp/css/cake.generic.css it sees the file but it does not see the file when I go to http://localhost/dvdcatalog/css/cake.generic.css

I think this means the cakephp folder is able to use .htaccess and the dvdcatalog is not.

I setup the cakephp directory last month when I was following in the blog tutorial. I am setting up the dvdcatalog directory now for a different tutorial. So I am not sure if I am missing a step.

in my /etc/apache2/apache2.conf file I have this:

<Directory "/var/www/*">
    Order allow,deny
    Allow from all
    AllowOverride All

Which I thought gave .htaccesss to all.

Does anyone have any ideas what the problem is?

share|improve this question
It would help to include the contents of your .htaccess file for dvdcatalog install. – carson Jan 6 '11 at 17:37
This may not be indicative of .htaccess not being allowed. put AuthUserFile /home/mysite/.htpasswd in your .htaccess file and then tail your log files. If you see an error (assuming .htpasswd doesn't exist) then .htaccess is being fired off but not doing what you had hoped for when using dvdcatalog tutorial. – Patrick R Jan 6 '11 at 17:43
@carson, so I go to check the contents of the .htaccess file for you and after change to view hidden files I notice that it is not there. I guess all the other files got copied over but the hidden files did not. I copied them over and it works now :) I guess I should have known better! – JD Isaacks Jan 6 '11 at 17:54
so you're issue is resolved then? might want to answer your own question below, check mark it, and bump up carson's comment.... just a suggestion. – Patrick R Jan 6 '11 at 18:00

Check the permissions on the .htaccess in the dvdcatalog directory? Should be readable by the group that your webserver is running as (or anyone really): chmod 644 .htaccess where owner is not the same user the webserver runs as (unsecure, but things like wordpress require the webserver to be able to write the htaccess file)

Other than that, need to see your .htaccess file contents.

share|improve this answer
The .htaccess file that was supposed to be there when I copied all the files over did not transfer over. I tried again and made sure the .htaccess files were copied over and it works now. – JD Isaacks Jan 6 '11 at 18:00

It turns out that when I transfered the files over to /var/www/dvdcatalog the hidden (.htaccess) files did not transfer over.

I tried again and this time verified they were copied. It now works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.