Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to use the htscanner PECL extension on my CentOS 5/PHP 5.2.6 machine, but there's a bug in the latest version where a newline character is added to the end of every php_value directive. This behavior causes my include_path and error_log values not to work.

The bug and the patch are documented on the PECL site: http://pecl.php.net/bugs/bug.php?id=16891

I've downloaded the latest version, applied the patch, and re-compressed the package — but I can't get the PECL installer to accept it — or any local package, for that matter.

I've tried every variation of the pecl install syntax that I can think of, and the only times I'm able to get it to work, it downloads an online copy first and ignores the local copy.

Can anyone recommend a method for installing a PECL extension from a local file? Thanks for your consideration.

share|improve this question

1 Answer 1

up vote 7 down vote accepted

If you have the (patched) extension source code locally you can bypass PECL entirely:

# cd extension_dir
# phpize
# ./configure
# make
# make install

(phpize is a binary that comes with PHP - It prepares the extension to be compiled, the rest is pretty straightforward).

share|improve this answer
1  
Perfect, thanks! One note: phpize && ./configure --enable-htscanner && make — I added --enable-htscanner as per the included README. –  JKS Jan 6 '11 at 20:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.