Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my system, have CentOS 5 and PHP 5.1.6. I tried to update php into version up(5.3)

yum update php
result: No Packages marked for Update

Anyone have any suggestions? Thanks!

share|improve this question
You might not want to do this. If you bodge 5.3.x and assorted dependancies into C5, you will end up with something which isn't a pure C5 system -- and if it breaks, you get to keep all the pieces. If this is something you think you are going to live with for a while, you might want to use a suitable Fedora to play with while waiting for C6 to come out. – David Mackintosh Jan 7 '11 at 3:46

For CentOS Version 4,

rpm -Uvh remi-release-4*.rpm epel-release-4*.rpm

cd /etc/yum.repos.d

rpm --import

yum --enablerepo=remi list php
php.i386 5.3.2-1.el4.remi

yum --enablerepo=remi update php

I upgraded PHP 5.3.4 in two different systems( CentOS 5.4 & 4.7 ) successfully.

share|improve this answer
Thanks, this worked for me where some of the others complained about huge lists of missing dependencies such as libc6 etc. – drew010 Feb 22 '13 at 16:58
up vote 2 down vote accepted

I tried the following Option to update PHP 5.3.4 successfully !!

For CentOS 5.4

rpm --import

webtatic RPM Install

rpm -Uvh

PHP Install

yum --enablerepo=webtatic install php

PHP Update

yum --enablerepo=webtatic update php
share|improve this answer
Note, Webtatic will be EOLing PHP 5.3 in a few weeks. This answer will no longer be relevant at that point, and stongly suggest PHP 5.5+ is used instead – Andy Sep 5 '15 at 19:17

By sheer coincidence I have just written this up for another question. I know this seems to be updating mysql, but it should force php to update and avoid a dependency issue. If php doesn't install by the time you have followed all the steps below, yum remove php and then run: yum --enablerepo=remi install php (and anything else you need)

Follow at your own risk etc:

NB: for 64-bit CentOS For 32-bit, leave off the .x86_64 suffixes

yum remove mysql mysql-server
su -c 'rpm -Uvh'
rpm -Uvh remi-release-5*.rpm
yum --enablerepo=remi install mysql.x86_64 mysql-server.x86_64 

You might need to tack on any extras you need to the last yum command - eg: php-mysql php-devel php-pdo

share|improve this answer

in CentOS 5.6 (and others, presumably), you can:

    yum install php53

if that gives you trouble, you may first have to

    yum erase php5
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.