Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today for strange reason, one of my Ubuntu 64 bit server Linux VM failed to start ? it stopped in the FSCK scan status with the error as attached. alt text alt text

few days back I've added new hard disk successfully and format it as sdb5 without problem.

Any guidance and comments will be highly appreciated.


here's the updatedalt text alt text

share|improve this question
Look to me like it might be an error in fstab, could we see your /etc/fstab ? – MadHatter Jan 7 '11 at 13:52
thanks for the reply mate, unfortunately I couldn't copy paste the /etc/fstab content here because the boot process was stuck as in the screenshot. – Server System Specialist Jan 7 '11 at 23:23
up vote 2 down vote accepted

The first screenshot seems to show a particular problem with fscking the device /media/extraspace/hudson/.m2/repository, which is in turn on the device LABEL=extraspace. You could try changing the fsck pass of the former to 0, with the line

/media/extraspace/hudson/.m2/repository   /var/lib/hudson/.m2/repository   ext4  bind,defaults   0 0

(changing the terminal 2 to a 0) and skip the fsck pass. That should let you get the system up and running, and hopefully you can then look into why that line's there and whether the device should be fscked at boot or not.

If that does help and you want to fsck at boot, try changing the 2 to a 3: I see that LABEL=extraspace is fscked in pass 2 also, and there's no way you can fsck a file system which is inside another file system which is currently being fscked, and is therefore not yet mounted.

share|improve this answer
wow, you're right I did change all of those 2 into all 0 since this is just a VM, so in this case for all of my LINUX VM i shall set the FSCK level all to 0 no matter what. – Server System Specialist Jan 8 '11 at 12:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.